Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Multicast hanging for multiple PCs

  • I'm testing the multicast for deployment of Windows image on classroom PCs.

    First I tried to create a "Multicast test" group, where I added one PC, which was freshly registered (can be found in "Search Image Only" list), chose my image configured for deployment on Bios&UEFI by setting aprtition deployment to "Standard" and it went succesfully without asking for my intervention to start the process.

    Then I tried deleting that one PC from the group and added 3 new PCs, also freshly registered in PXE booting. I created "Multicast On Demand" task with the same image and profile for 3 clients and the only Com server I have (which is on different VLAN - using Cisco 3560G VLAN routing, with multicasting enabled - it works well with FOG deployment).
    All 3 PCs get to the point, where they ask for my input to start sending data (which is used for starting multicast anyway, if there is a PC, that failed to connect due to hardware issues for example, I think - correct me if I'm wrong). After I tap a key on one PC, it shows "Sending go signal" and nothing happens. The same thing happens if I press random key on other PCs additionally as well, which show the same message and just hang. (pics below)









  • In your multicast receiver arguments, try adding:

    --mcast-rdv-address [com-server-ip]



    you should also try to disable your firewall temporarily just to rule that out.

  • @theopenem_admin, tried it yesterday as you suggested, but no luck - same result.

  • @theopenem_admin, also I tried to run the multicast again today, but tapped the key on the first connected PC sooner then the dialog showed on other 2 PCs and it started on the first PC, and the other 2 just hanged and shut down eventually.

  • @theopenem_admin, any ideas?

  • Can you try multicasting with just a single computer?

  • @theopenem_admin that works without any issues, though

  • Did you start a multicast session with just a single PC or did you do a unicast. If a multicast session works with a single PC then everything is working properly, but something is preventing the multicast to multiple pcs.

  • @theopenem_admin yes, I mentioned it in the first post - I tried running multicast as a task for a group made of 1 PC and also as a on-demand task for 1 PC and it worked flawlesly... it even worked when I started multicast for a group of 3 PCs, but tapped a key as soon as it showed the dialog for starting deploying on the first PC, and the other PCs weren't ready...
    But if another PC connects, it just hangs on that screen waiting for something.

  • The only other thing I could think of is to change the multicast block size. In your sender arguments try using:

    --blocksize 700

  • @theopenem_admin after setting this option in Com Server Multicast settings, after I click start multicast for a group, it says "Could not start the multicast application"

  • Fixed it - had to add a space before "--blocksize", or it wasn't in the command:

    07-27-22 08:01 Starting Multicast Session With The Following Command:
    cmd.exe /c ""C:\Program Files\Theopenem\Toec-API\\private\apps\udp-sender.exe" --file "O:/\images\Win10-EduPro-IDE_Test\hd0\part2.ntfs.lz4" --portbase 9370 --min-receivers 2 --ttl 32 --interface X.X.143.115 --mcast-rdv-address X.X.143.115--blocksize 700"
    Session Started And Was Forced To Quit, Try Running The Command Manually

  • FWIW, I have the same situation, and the only thing that seemed to work for me was to make sure that all storage settings were set to local, on the main server, and secondary com servers, and to make sure upload/deploy direct to SMB was disabled. Works like a charm after that.

  • @hodgesc I've got the system as Proxmox VM with 50GB C:\ drive and 1TB O:\ drive, which has the images. I don't use any secondary servers (although I think having one server per VLAN would work, I don't think it's the right way to do it, as I have system with like 5 VLANs or so) and I've never used the SMB option. Also "deploying via SMB" is a thing?

  • @eruthon Upload/Deploy Direct to SMB is the last option under Admin Settings --> Imaging Client. To multicast across VLANs, you'd have to have a com server on each vlan and run the multicast session through there.

  • @hodgesc And the com server has to be a standalone windows server with its own installation of TOEM or it could be just one windows server with one toem, but set up with multiple network interfaces and I'd just add different com servers on those networks?

  • @eruthon what I think you'd actually have to do if you just want to use one actual system to run this on multiple network interfaces, is to:

    1. Clone the TOEC-API site for each IP.
    2. Bind each IP to the site in IIS
    3. Setup a "com server" for each IP in the UI.
    4. Modify the web.config for each com server and verfiydb.
    5. Add them to the default cluster as passive servers with the multicast, TFTP, and imaging options.
      (edit) 6. Go into HeidiSQL, change the root account to have remote access. (almost forgot that)

    That should do it I think.

  • @hodgesc
    You are 100% correct. Love seeing people with an understanding of how things work, not to discount others that are still learning.

  • @hodgesc will try, thanks for steps, will let you know if it works!