Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

ApiRequest - Invalid Reponse, Signature Missing

  • I am running into an issue where my clients are getting an Invalid Response

    I have no Idea what is causing the issue, but once they get this message, they no longer will receive policy or send updates tot he server

    ApiRequest - Invalid Reponse, Signature Missing:  ProvisionedComm/Provision/ConfirmProvisionRequest/

  • Is it all of your clients or just some?

  • @theopenem_admin It is most of my clients. It seem to be mostly my Windows 11 Machines that have the issue much more than my windows 10 machines

  • Can you verify the needed certs are on this computer.
    In certificate manager, computer certs, personal there should be a cert that is just a guid and issued by Toems Intermediate

  • I see the Toems Intermediate and its valis till 2032

  • Do you see the cert with a name that looks like a guid?

  • yes a49e98.......

    I turned on Debug logging, I am seeing a lot of "The Request was Unauthorized"

    ApiRequest - The Request Was Unauthorized ProvisionedComm/Policy/UpdateLastSocketResult/
     ApiRequest - The Request Was Unauthorized ProvisionedComm/Provision/RenewSymmKey/
    2022-07-27 14:11:49,159 DEBUG [4] ApiRequest - Provision/ProvisionClient/
    2022-07-27 14:11:50,606 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-27 14:11:51,705 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-27 14:11:51,706 DEBUG [4] ServiceInitialize - Provision Client: Error

    I also moved from using the internal IP address of the Server to using an IP address that is accessible from off site a couple of weeks ago. I updated the Server UI with the new IP address and updated Toec. Just want to make sure that is not part of the issue.

  • @cmcfarlane
    Interestingly enough, I just started getting this error as well. We have not made any major changes in our deployment.

  • This is definitely concerning. I haven't come across this yet, I wonder if it's a Windows update. Can you change your toec-api web.config file to debug for logging. It's towards the bottom, change the line to:

    <level value="DEBUG" />

    After a few of these try to checkin, can you post the log?

  • @theopenem_admin
    We did just install updates over the weekend on our servers. I'll enable debug and report back tomorrow.

  • @brywhi Interestingly enough, haven't seen any more since turning on debug and rebooting the TOEM com server.... I'm a bit confused at what happened. I'll again if it comes back 🙂

  • service-cp-i-0001.txt
    Here is the log file of one of the computers, I have had to be at a training all day. I changed the log setting at 7:30 AM and rebooted the server to be on the safe side, but it doesn't look like the computer changed the logging.

    I checked 4 other computers, they seem to be ok, but I need to check the larger stack that I know where having issues.

  • @theopenem_admin Here is an additional log file

    It seems that changing the log setting in the UI did not propagate to the problem clients. the below is the section of the log after I manually changed the Log level

    2022-07-29 09:48:01,386 DEBUG [4] ApiRequest - Provision/GetStartupInfo/
    2022-07-29 09:48:01,583 INFO [4] ServiceInitialize - Threshold Window Enabled.  Delaying For 33 Seconds.
    2022-07-29 09:48:34,594 INFO [4] ServiceProvision - Verifying Client Provision Status
    2022-07-29 09:48:34,653 INFO [4] ServiceProvision - Verification Complete
    2022-07-29 09:48:34,670 DEBUG [4] ApiRequest - Provision/GetIntermediateCert/
    2022-07-29 09:48:35,041 ERROR [4] ServiceAD - Active Directory Search Failed: 
    2022-07-29 09:48:35,042 ERROR [4] ServiceAD - Current security context is not associated with an Active Directory domain or forest.
    2022-07-29 09:48:35,044 DEBUG [4] ServiceProvision - Gathering Hardware Details
    2022-07-29 09:48:36,408 DEBUG [4] ApiRequest - Provision/ProvisionClient/
    2022-07-29 09:48:38,061 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:48:38,704 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:48:38,705 DEBUG [4] ServiceInitialize - Provision Client: Error
    2022-07-29 09:49:08,732 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:09,302 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:09,303 DEBUG [4] ServiceInitialize - Provision Client: Error
    2022-07-29 09:49:39,340 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:39,827 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:39,830 DEBUG [4] ServiceInitialize - Provision Client: Error

  • These are all client logs. I'm looking for the server log.

    Server logs

  • @theopenem_admin Sorry, I miss understood you wanted the server log
    here is the log

    Thank you very much for all the help

  • @theopenem_admin How also found that if I change the Comserver from the Command Line on the client ( from Ext to int Ip of the server ) the computer will connect, update and than get an Signature Missing Error

  • I don't see anything that really stands out, other than the computer saying it already exists. What happens if you delete the computer from the UI? Does it re-register itself properly?

  • @theopenem_admin It will reregister, but it will get the same error immediately.
    the Ui will show for the last check in 1/1/0001 12:00:00 AM
    If I change the ComServer than it works for the check in for a bit then it will go back tot he error.

  • I can't think of anything else that could be causing this. If you uninstall the client and then manually delete the program files\Toec directory, does it fix it?

  • @theopenem_admin
    I just unistalled the client, deleted the folder, did a new install and it is the same issue.
    Signature missing came up the second it tried to connect.

    I did a full reset and I got an error
    Could not find device Certificate with Thumbprint XXXXXXXXX
    Resetting Toec Finished
    than Invalid Response