Welcome to the community forums for Theopenem. You are encouraged to not only ask questions but help others as well. If you have found Theopenem helpful in any way please consider purchasing a support contract. A support contract ensures the continued development of Theopenem as well as guaranteed responses to your questions in our helpdesk ticketing system.

ApiRequest - Invalid Reponse, Signature Missing

  • @theopenem_admin Here is an additional log file

    It seems that changing the log setting in the UI did not propagate to the problem clients. the below is the section of the log after I manually changed the Log level

    2022-07-29 09:48:01,386 DEBUG [4] ApiRequest - Provision/GetStartupInfo/
    2022-07-29 09:48:01,583 INFO [4] ServiceInitialize - Threshold Window Enabled.  Delaying For 33 Seconds.
    2022-07-29 09:48:34,594 INFO [4] ServiceProvision - Verifying Client Provision Status
    2022-07-29 09:48:34,653 INFO [4] ServiceProvision - Verification Complete
    2022-07-29 09:48:34,670 DEBUG [4] ApiRequest - Provision/GetIntermediateCert/
    2022-07-29 09:48:35,041 ERROR [4] ServiceAD - Active Directory Search Failed: 
    2022-07-29 09:48:35,042 ERROR [4] ServiceAD - Current security context is not associated with an Active Directory domain or forest.
    2022-07-29 09:48:35,044 DEBUG [4] ServiceProvision - Gathering Hardware Details
    2022-07-29 09:48:36,408 DEBUG [4] ApiRequest - Provision/ProvisionClient/
    2022-07-29 09:48:38,061 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:48:38,704 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:48:38,705 DEBUG [4] ServiceInitialize - Provision Client: Error
    2022-07-29 09:49:08,732 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:09,302 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:09,303 DEBUG [4] ServiceInitialize - Provision Client: Error
    2022-07-29 09:49:39,340 DEBUG [4] ApiRequest - ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:39,827 ERROR [4] ApiRequest - Invalid Reponse, Signature Missing: ProvisionedComm/Provision/ConfirmProvisionRequest/
    2022-07-29 09:49:39,830 DEBUG [4] ServiceInitialize - Provision Client: Error

  • These are all client logs. I'm looking for the server log.

    Server logs

  • @theopenem_admin Sorry, I miss understood you wanted the server log
    here is the log

    Thank you very much for all the help

  • @theopenem_admin How also found that if I change the Comserver from the Command Line on the client ( from Ext to int Ip of the server ) the computer will connect, update and than get an Signature Missing Error

  • I don't see anything that really stands out, other than the computer saying it already exists. What happens if you delete the computer from the UI? Does it re-register itself properly?

  • @theopenem_admin It will reregister, but it will get the same error immediately.
    the Ui will show for the last check in 1/1/0001 12:00:00 AM
    If I change the ComServer than it works for the check in for a bit then it will go back tot he error.

  • I can't think of anything else that could be causing this. If you uninstall the client and then manually delete the program files\Toec directory, does it fix it?

  • @theopenem_admin
    I just unistalled the client, deleted the folder, did a new install and it is the same issue.
    Signature missing came up the second it tried to connect.

    I did a full reset and I got an error
    Could not find device Certificate with Thumbprint XXXXXXXXX
    Resetting Toec Finished
    than Invalid Response

  • Is your com server behind a load balancer or anything that could change the api request?

  • @theopenem_admin
    nope, the only thing I changed recently was the IP address they Com server was using. I went from the inside address to a port forwarded address.