Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

  • We have some HPzbook 15 G2, we imaged with CD, now we changed to TO, and we have some issues with a image, wich deploys on most of the Laptops.
    On some Laptops, it does not deploy correctly, and stops on the partition Creation script.

    in the deploy log the last enties are

    Command (m for help): Partition number (1-3, default 3): Hex code (type L to list all codes):
    Changed type of partition 'Extended' to 'Extended'.

    Command (m for help): Partition type
    p primary (3 primary, 0 extended, 1 free)
    e extended (container for logical partitions)
    Select (default e):
    Selected partition 4
    First sector (377536641-500118191, default 483354624): Value out of range.
    First sector (377536641-500118191, default 483354624): Last sector, +/-sectors or +/-size{K,M,G,T,P} (483354624-500118191, default 500118191):
    Created a new partition 4 of type 'Linux' and of size 943 MiB.

    Command (m for help): Partition number (1-4, default 4): Hex code (type L to list all codes):
    Changed type of partition 'Linux' to 'Hidden NTFS WinRE'.

    Command (m for help): To create more partitions, first replace a primary with an extended partition.

    Command (m for help):

    Command (m for help): +: unknown command

    Command (m for help): Partition number (1-4, default 4): Value out of range.
    Partition number (1-4, default 4): Value out of range.
    Partition number (1-4, default 4): Value out of range.
    Partition number (1-4, default 4):
    Command (m for help):

    ** An Error Has Occurred **

    ...... Could Not Create Partition Layout

    maybe someone can give me a hint whether it's the image or another problem

    upload log
    ZBOOK5 04-09-2021_11_52-ondupload(1).txt

    deploy log with error
    ZBOOK18 04-13-2021_11_31-onddeploy.txt

    working deploy log:
    ZBOOK00 04-12-2021_17_45-onddeploy(1).txt

  • Your issue is that Extended partitions are being used, which is very strange. Did you create this partition layout or did it come that way from the factory? Theopenem doesn't really support extended partitions. The working one works because the hard drive is the exact same size as the original, the other one requires that partition table to be dynamically created. If you need more than 4 partitions, an EFI layout would be the way to go.

  • @theopenem_admin
    thanks for your fast reply, i will create a new image from scratch.

    the original image was created last year, and after some windows updates and reimaged from different machines i think the partition table gets confused. the original image worked perfect with CD
    thanks a lot for your help.

  • Sure, your other option is to set the partition type to standard in the image profile, which should save you from needing to recreate the image. It will create a standard partition table for you. You just need to select the correct windows partition when asked.

  • @theopenem_admin
    Thanks for this advice,
    works great, I deployed the Windows partition in this way, created the 2nd empty data partition and uploaded the new image as new image, which deploys without errors on all devices as expected.

    btw, i m missing the "permant deploy" option, is this part for future release or is it already implemented and i dont see this.

    thanks Ralf

  • The permanent deploy feature was removed. I tried to scale back on features that only most people were using. However, the model match feature may work for you if you are using the same image based on models. I mean if a single model always gets the same image, it could work for you.