Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Getting Timeout While PXE Boot attempts to load

  • Getting a Time Out While PXE Boots. I believe it is from the tftp server but not sure why.
    I had something similar to this back several months ago and we changed to the cd_proxyd as the proxy helper and all went away. This time ti does not seem to be working and I am stumped.
    It starts to load and then when tftp send the firs file is states Client Disconnect.
    See attached pics for details
    I have also uploaded the Proxy Config
    I have updated to the latest version of TOEM 1.3.3
    Just incase
    Any help is much appreciated

    TOEM-Error1a.jpg TOEM-Error3a.jpg TOEM-Error2a.jpg
    [0_1621539996130_cd_proxy_config.ini](Uploading 0%)

  • Is this happening for all models or just this one. Your tftp server is missing for some reason. The last line says tftp:///proxy when it should be tftp://

  • It appears to be happening on All devices.
    I just tried several different Dell Models that have been working just fine.
    I do not recall making and changes to any part of the TOEM.
    Is this related the Proxy helper or the tftp server?
    I don't know where to look
    The proxy CFG is attached

  • Since it loads the pxeboot file but not the default config file, it doesn't seem config related, or it wouldn't get to that step. What are you using for dhcp?

  • Microsoft DHCP Service

  • Is there anything I can check on my network that could cause this.

  • Option 66 and 67 are disabled correct?, not just empty?

  • @theopenem_admin
    in DHCP I assume?
    see pic for the options

  • @theopenem_admin
    I have found one issue that I am not sure is the issue.
    I see that our Director or Admin has configured Microsoft DHCP Failover.
    That doesn't bother me as much as the option to load balance DHCP addresses
    so could this be the issue.
    I am not sure I have the credentials to remove this but if it is the problem then I have some things I will have to change.
    I am thinking of just putting the cloning process into its one Vlan and having a different DHCP server all together.
    Just more work and time I have to find.
    Thanks for the help

  • So I disabled the Load balancing on the DHCP servers we have. It should be setup as Failover now.
    I am getting most of the time an error from PXE of PXE-E99 Unexpected Network Error.
    Not exactly sure what to do with this.
    I see that it is getting an IP but then it hangs
    I have fired up the CD_Proxyd in debug mode and the tfpt Gui to see if I could se any issues nothing.
    I am stuck dead at this point.


  • Have you tried not using the proxy?

  • @theopenem_admin
    No, Don't I need to add the 2 options in our DNS then?

  • yes, then change your pxe mode in the toems ui.

  • @theopenem_admin
    So I can make sure I have everything correctly disabled for ProxyBoot and I have set the correct options in DHCP and TOEMs

    I have set options 66 and 67 in DHCP Server.
    66 points to the ip of the TOEMs server
    67 is set to this pxeboot.0
    I have disabled the Proxy DHCP under Admin/PXE Boot Settings
    See screen shots for details
    I think this is all I needed to do.
    Have I missed anything as it is still can't get it to load
    I am getting a different PXE Error
    PXE-E16: No valid offer received.
    It appears I am not getting an IP Address. It sits at " Start PXE over IPv4" for like 30 seconds and then times out with the PXE-E16 error.
    I can find nothing wrong with our DHCP server.

    Disable Proxy DHCP.JPG

    DHCP Option 67.JPG

    DHCP Option 66.JPG

  • it's difficult to say what's happening. It appears you have it setup correctly. Can you post your tftpd32.ini file located in C:\Program Files\Theopenem\tftpd32

  • @theopenem_adm
    Please find the tftpd32.ini config file attached.
    [0_1623179927592_tftpd32.ini](Uploading 0%) in

    BaseDirectory=C:\Program Files\Theopenem\tftpboot
    DHCP Ping=0
    Max Simultaneous Transfers=100
    Console Password=tftpd32
    Support for port Option=0
    Keep transfer Gui=5
    Ignore ack for last TFTP packet=0
    Enable IPv6=0
    DHCP Double Answer=0
    DHCP LocalIP=

  • Does the TFTP config file look correct?

  • Yes, as far as I can tell everything is setup correctly. I can't pinpoint your issue at the moment.