Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Toec client - The Request Was Unauthorized Provision/ComConnectionTest/

  • Hello all,

    I am a new user of Theopenem, so I hope my question is not too dumb for this forum.

    I support local schools with their server and client management and I am using opsi for that until now. I am currently evaluating theopenem as a replacement, at least for the os deployment.

    I followed the getting started tutorial (very nice, thanks for that), installed the server (lastest version) on a domain joined windows 2019 server, configured it and then installed the exported client msi on a windows 10 20H2 client - fresh install, no modifications made.
    Unfortunately the client is not able to authenticate at the server. The log says:

    2021-05-30 16:44:00,287 ERROR [4] ApiRequest - The Request Was Unauthorized Provision/ComConnectionTest/
    2021-05-30 16:44:00,287 ERROR [4] ServiceActiveComServer - Could Not Connect To Any Client Com Servers.  Delaying 30 Seconds Before Next Retry.

    I double checked with wireshark - server has ip, client has ip

    195108	2586.246139	HTTP	407	GET /Provision/ComConnectionTest/ HTTP/1.1 
    195109	2586.257693	TCP	54	8888 → 49251 [ACK] Seq=9505 Ack=11674 Win=2101504 Len=0
    195110	2586.259726	HTTP	351	HTTP/1.1 401 Unauthorized

    I tried the URL in my browser and got a http authentication: I was not able to login with my toemsadmin credentials.

    I reread the tutorial, watched the tutorial youtube videos part 1&2, did the complete install from scratch again, tried the options in Admin Settings => Security and the problem is reproducable and persists. I still have no clue, why I get this 401 unauthorized error.

    Anyone able to help me with this?

    Best regards,

  • Have you installed the certificates on the server? Can you verify the time and date on both the server and client are the same?

  • @theopenem_admin
    certificates where installed but ... the timezone on the default install of the client was wrong. Now it works, thank you!