Welcome to the community forums for Theopenem. You are encouraged to not only ask questions but help others as well. If you have found Theopenem helpful in any way please consider purchasing a support contract. A support contract ensures the continued development of Theopenem as well as guaranteed responses to your questions in our helpdesk ticketing system.

  • I have a batch of PCs (Acer Aspires) that are failing when configuring in IPXE. They fail with
    Error 0x040ee186 (http://ipxe.org/040ee186) which says it's No Configuration Method succeeded.

    Any idea if there's something I can change in the PXE boot configuration?


  • I guess what I'm wondering is, is there a way to add a driver to the ipxe installation that may get around the issue? There don't appear to be any firmware updates for the network card. They also won't let me boot from USB, it's simply not an option in BIOS to be enabled. I'm thinking adding a driver to ipxe is the step I'm missing.

  • Just punting, but did you try Admin Settings->Kernels->5.11.10x64->Download
    Then Update your PXE boot Menus to that Kernel? (Seems they all default to the 5.10 version so change each time and hit update.

  • @dangbird I did do that this afternoon 🙂 Sadly, it didn't help.

  • Follow up to this: I was able to boot from a TOEMS USB, but as soon as I select TheOpenEm, it goes to a black screen with a non-flashing cursor, and stays. I'm guessing it's the same issue, network adapter isn't working with the kernel, and dying as soon as the kernel loads. I'm at a loss.

  • You tried all the Boot Options - ipxe_efi64 and grub and winpe_efi64?
    If I boot to a VM thru PXE or USB I could not get anything to work until I switched to GRUB for 64 bit efi...
    I had some Intel NUC's that were very new with new chipsets so it was all ticked off, until I set the NUC to ipxe_efi64 etc. Anyhow could be totally not your issue, but hoping it might help you out.

  • I've tried it with a WinPE USB, and every possible configuration, except GRUB, and that's only because I don't remember what to do there once I get to the "GRUB" prompt.

    Soon as it tries to get an IP, it seems, it fails. Usually resulting in proceeding to boot off the hard drive.

    I'm running out of ideas.

  • Well hopefully the Dev will respond, I am seeing some PXE issues in general or ignorance to how it is setup. Likely there are a few bugs, and or issues with newer chipsets.

    One option I have been successful with on newer hardware, is to set the Network Stack in Bios to "Legacy" vs "EFI" if its available. Then I can do the cloning successfully, and then after the clone it boots EFI etc since the Image is EFI of the machine in question.

    Not sure if your Units have that option in Bios, but if they do it sometimes works because of the different Stack Software load, it can work with Older Kernels etc.

    Hoping we can all get TheOpenEm to work, as it is very slick for the most part, I think its just early on.

  • The BIOS on this particular device is most unhelpful. Legacy isn't even an option, for anything. I love TheOpenEM, and I've had great success on many machines so far. Except these. Wish I hadn't ordered them now. 🙂

  • ipxe is configured with a universal driver. If your machine doesn't support that, which it seems about 99% do, it's not going to work. Have you tried with snp and snp only?

    You will most likely need to usb boot these machines. When creating the iso, you will need to disable secure boot support from the web ui and also on the computer itself. That will resolve the stuck cursor issue. These newer machines aren't supporting the older shim.

  • @theopenem_admin Yeah, my current situation is, no matter how I boot it, it fails either on ipxe, or with usb, right after I select TheOpenEM it goes to a blank screen and hangs with a solid cursor in the corner. These machines have been a nightmare.

    Welcome back by the way. Are you dealing with start of school as well? 🙂

  • @theopenem_admin said in ipxe failure:

    When creating the iso, you will need to disable secure boot support from the web ui and also on the computer itself. That will resolve the stuck cursor issue. These newer machines aren't supporting the older shim.

  • @theopenem_admin Great, I'll give that a shot. thanks

  • Man, these things are awful. That let them get to TheOpenEM fine, and all the way through image selection, and they fail showing no hard drive. The BIOS on these things is so restrictive, I can't put it into Legacy Mode. I tried 5.11.10, 5.6.4 and 4.18.5. I'll come back to it in the morning.