LDAP Bind Error



  • Can't get LDAP to connect to our AD service. I have been using LDP.exe to check and it is working fine but can't seem to get it to work from the "Admin Settings" - Test AD Bind option get the error Bind Failed. Check Exception log for more info.



  • @ggalindo
    The error in the application log is this;
    2020-06-10 08:48:37,689 [15] DEBUG Toems_ApplicationApi.Controllers.Authorization.CustomAuthAttribute http://localhost:8080/Setting/TestADBind/
    2020-06-10 08:48:37,720 [15] ERROR Toems_Service.EncryptionServices Could Not Decrypt Password. Ensure Your Encryption Key is Correct.
    2020-06-10 08:48:37,768 [15] DEBUG Toems_Service.Workflows.LdapSync Active Directory Bind Failed.
    2020-06-10 08:48:37,768 [15] ERROR Toems_Service.Workflows.LdapSync An operations error occurred.

    I have turned the following back on and regenerated the Provisioin Key several times
    <add key="AllowProvisionKeyGen" value="true" />



  • Are you using only a single server? Do your Db encryption keys in your web.config files match?



  • @theopenem_admin
    Yes one Server only Windows 2016
    Yes it is the same in the toec-API and toems-API Web config files
    is that the data that needs to be entered into the Provision key on the security tab?
    I tried it both was with that key and with generating a key using the Action Generate Provision Key
    neither way worked
    Thanks



  • The provision key is for something else, you should just use the generate button for that. Your log is indicating the password that was saved for the ldap password cannot be decrypted. Can you type the password in the ldap settings again and click update ldap settings. Then click test ad bind. Post log again if it's not working.



  • So it appears I have it working.
    I re-generated the key
    Restarted the server
    went in and retyped the password in LDAP and changed the LDAP Auth Type to Secure.
    Updated the changes and clicked Test and it worked.
    Not sure why as I did this same thing several times
    But it is working.
    Sorry to have bothered you