Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Printer module,script and command do not install printers over the network

  • I am really struggling with the printer module I have tried it on 3 different settings, the printer module, a script and a command and none are installing the printers but I get exit code 0 meaning successfull deployment. I run those commands separatedly and ALL work fine and my printers install so I am not sure where the issue is at at this point but when i run this from theo i get nothing.

    printer module code: '\printerserver\printer name' ; Action: installPowershell
    -module run on device: powershell.exe add-printer -connectionName "'\printerserver\printer name'"

    Command module code: command: powershell.exe ; Arguments: add-printer -connectionName '\printerserver\printer name'
    -extract of code run on the device: cmd.exe /c "powershell.exe" add-printer -connectionName '\printerserver\printer name'

    Script run on machine: script type: powershell
    $printclass = [wmiclass]"win32_printer"
    $printclass.AddPrinterConnection("\printerserver\printer name")
    $printclass.AddPrinterConnection("\printerserver\printer name2")
    #$printclass.AddPrinterConnection("\printerserver.company.com\LAB A Color")
    #$printclass.AddPrinterConnection("\printerserver.company.com\LAB A Duplex")

    Script run on device:
    -powershell.exe -executionpolicy bypass -noprofile -file "location of script.ps1"

  • Printers are typically a per user item. You would want the policy trigger to be login to run as that user and not the system account.

  • @theopenem_admin can you specify this? meaning where do you trigger this from or the config for the module?

  • It's on the policy. Change the trigger type.