Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Enabling SSL on the webGUI

  • Hi,

    I'm running theopenem servers on a single Windows 10 box in my home lab and also have NGINX Proxy Manager on my network. I want to point https://toems.mydomain.com at the server and have SSL access to the Web GUI.
    I can access the WebUI via, no problem; however, I cannot connect via https on the IP or via the https://toems.mydomain.com URL.
    I have verified that ports 443, 4444, and 8443 are all open in the Windows firewall, and I'm accessing the server from the same subnet so there is no filtering of the traffic.
    It may be that the server is not listening on 443, but I'm not sure where to make that setting change. In the webconfig file I followed the directions and put I'm guessing that has nothing to do with this as it is stated to be to allow communication between the SQL DB and the API server.

    Any help is appreciated!

  • There is nothing specific for setting up https in Theopenem. It's the standard process for setting up IIS with SSL. You need to assign a certificate to the sites in inetmgr

  • @theopenem_admin
    Thanks for pointing me in the right direction. There was no https binding and I'm getting that set up now.