Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Force Checkin not working at group level

  • Maybe I'm missing the obvious here. I've created a couple Dynamic groups to push software, and after running "test query" and saving the Dynamic criteria, have a group of PCs that in one case were to receive Thunderbird and another to receive 7-Zip.
    In both instances running the "Force Checkin" command from within the group indicates that it was run successfully, but the computers do not take the push.
    If I run "Force Checkin" at the computer level, it checks in and installs the software perfectly. Do I have something misconfigured or just misunderstand what is happening here?

    Edit: The same applies to the "Collect Inventory" command --works fine on individual PCs, and it says it works at group level but nothing changes.


  • It looks like the force inventory command on the group has a bug and is incorrectly calling the check in function. However the force checkin on the group should be working. After run the force checkin, check the service log on one of the clients and look for the line:

    Manual Checkin Request Received

    If it has that then it worked

  • @theopenem_admin
    Thanks! I think the inventory bug is what was causing the issue I saw - I was not seeing the deployment had happened and thought the failure was with Checkin. When I went to the Computer level and ran the commands I always ran the Checkin first, and then looked at the inventory. I assumed Checkin at group is what wasn't working, but probably had; the reality is the push had happened but the inventory hadn't updated until I ran Inventory on the Computer side.

    Thank you for checking into it!