Welcome to the community forums for Theopenem. You are encouraged to not only ask questions but help others as well. If you have found Theopenem helpful in any way please consider purchasing a support contract. A support contract ensures the continued development of Theopenem as well as guaranteed responses to your questions in our helpdesk ticketing system.

Problem booting WIE imaging


  • Here I am again! 🙂

    I have another problem now: PXE booting works, system is setup to boot WIE image, and it boots, but then it reaches a stage where it stops and exclaims that the NIC doesn't have IP adress and that the driver could not be found.

    When I enter "Display available NICs", I get two NICs displayed; first one is Microsoft Kernel Debug Network Adapter, and it has no address assigned. Second one is Realtek PCIe Gbe Familly Controller, I can see its mac address, IP address, it says that ipenabled is True and dhcpenabled is True. Yet it doesn't boot further from this point.

    I have no experience with Windows PE whatsoever, I have general idea what it is, and I don't know what to do at this point. Images were build on my work computer and transferred to server. Same thing happens if I boot ISO off USB drive.

    Also, there is line that says this:
    Try Entering http://10.1.36.30/clientimaging/Test In A Web Browser
    That is the IP adress which had to be entered into CMD file when starting building WIE images, right? But that link doesn't work without port 8888 after IP adress. Could that bie the problem, should I enter port with IP address?
    That part in build CMD looks like this now:

    set ComServerURL=http://10.1.36.30/
    

    Should it be

    set ComServerURL=http://10.1.36.30:8888/
    

    ?

    Relevant pictures attached.

    IMG_20221122_110029900_HDR.jpg
    IMG_20221122_110046185_HDR.jpg


  • @itisljar

    To reply to myself, the problem was this:

    set ComServerURL=http://10.1.36.30/
    

    It NEEDS to have port set up, too. It should look like this:

    set ComServerURL=http://10.1.36.30:8888/
    

    Now just to learn how to set up HR keyboard, that would be grand 🙂 anyone?
    EDIT: I'm dumb. Configuration for keyboard is in CMD file for building WIE.


  • Thanks for the updates, glad you got it figured out.


  • @theopenem_admin Haha yeah, I love troubleshooting these things which are not documented anywhere. I do have a problem though, can't get HR (Croatian) keyboard to work.

    I have setup CMD file for building like this:

    set TimeZone=Central European Standard Time
    set MyLang=hr-HR
    

    Whatever I do, I can't get Croatian keyboard to work. It's important because it has letters in different positions. Where should I configure that, somewhere in scripts, perhaps, but I don't see where...?

    I've found a way to change it manually, but I want it to build with a command. Can you help me with that? I've found what my input locale is:

    InputLocale=041a:0000041a
    

    But where do I enter that? Could you make a change in building scripts to make default system locale user's choice, if not setup, would make default en-US?

    EDIT: the reasons I ask you these thinks is your announcement that you will work more on WIE since you can't get shims for linux approved for secure booting, and I think this would be excellent addition to great script you made for creating WIE.

    Thank you.


  • An option for input local is now available in wie builder 2.0.2 for use with Theopenem 1.5.0.