Welcome to the community forums for Theopenem. You are encouraged to not only ask questions but help others as well. If you have found Theopenem helpful in any way please consider purchasing a support contract. A support contract ensures the continued development of Theopenem as well as guaranteed responses to your questions in our helpdesk ticketing system.


  • After successfully installing, I carefully following all the instructions on Server setup, I'm getting this error while attempting to upload an image from a client:
    "......Could Not Start Server Image Receiver"

    Application Log:
    2021-01-06 09:28:45,529 [41] ERROR Toems_Service.ServiceOnlineKernel The remote server returned an error: (403) Forbidden.
    2021-01-06 09:29:33,688 [42] ERROR Toems_Service.ServiceOnlineKernel The remote server returned an error: (403) Forbidden.
    ^unknown if related

    Front End:
    2021-01-06 09:29:33,688 [38] ERROR Toems_ApiCalls.ApiRequest Response Data Was Null For Resource: OnlineKernel/Get
    2021-01-06 09:32:25,137 [8] ERROR Toems_ApiCalls.ApiRequest Response Data Was Null For Resource: FileSystem/GetSMBFreeSpace/

    Com Server - multicast:
    cmd.exe /c "C:\Program Files\Theopenem\Toec-API\private\apps\udp-receiver.exe" --portbase 9008 --interface http://[myip]:8888/ --file F:\Deployment\images\Win10\hd0\part1.ntfs.lz4
    Session Win10 Started And Was Forced To Quit, Try Running The Command Manually
    ^Consistantly repeats every time an upload task is scheduled

    I'm assuming it has to do with the udp-receiver not working properly, but I'm at a loss.
    I really appreciate all your hard work.


  • --interface http://[myip]:8888/

    That is incorrect. When you filled in the ip address for the com server's upload interface ip, you need to just use an ip address, not the comserver url. The same should be true for the multicast settings and tftp settings.


  • @theopenem_admin Apologies, but I just removed that myself for this post, the IP is populated correctly in the logs.


  • That's not what I was referring to.

    --interface http://[myip]:8888/
    

    should look more like

    --interface [myip]
    

    Notice it's just an ip, not a url. This indicates you filled in the com server url in places where it should have just been an ip address.


  • @theopenem_admin Ohhhh, I misread you. Thank you for the prompt reply, it's uploading now! Hopefully this is the last misconfiguration on my part... -.-