Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Windows 11 fails to complete install after deploy

  • I'm getting a terribly helpful message from Windows 11 after deploying a newly created image. "Windows could not complete the installation. To install windows on this computer, restart the installation."

    Clicking Ok reboots the PC, and leave the "finalizing" screen as the background, but does not join the computer to the domain or finish setup. I used the same unattend I've used for countless Win 10 installs, and also tried creating a new one.

    Has anyone else run into this, or has anyone spotted a fix for this? I'm desperate, as we've got a very tight window for re-deploying our fleet this summer.

  • Haven't run into this yet, I can run some tests.

  • @theopenem_admin This is with the newest 22H2 image, by the way. And I had to use the Windows Installation Media creator to get the installer to recognize the hard drives on this device.

  • Here's exactly what I'm doing. I've tried this on multiple systems now.

    Installed new Windows 11 on PC via USB. At country selection use Ctrl-Shift-F3 to go into audit mode. Run all updates, use ninite.com to install Chrome, VLC Player, Google Drive, and WinDirStat. Install toec. Wait for toec to register with com server (which sometimes fails, unsure why).

    Then run Toec-Sysprep, connect to com server, select the unattend file, and then sysprep.

    If I boot THAT machine after uploading the image (or before uploading it), it tells me "Windows could not complete the installation. To install windows on this computer, restart the installation."

    I'm at a loss. I'm not sure if something about the toec portion of imageprep is removing something that's needed, or if there's something wrong with my install media (A theory I'm going to test right now)

  • I haven't been able to replicate this. Using Win11 22H2, boot to audit mode, install toec, run image prep, leave all default options, select setupcomplete file and sysprep file, finish image prep, capture image, then deploy. All works as expected. Let me know if you find the issue.

  • @theopenem_admin I'm not familiar with the setupcomplete file. What might I need to do with that? I've never messed with it beyond the defaults.

  • It's not required, just an easy way to run some extra commands after the computer boots the first time. It wouldn't change your issue since you aren't getting that far.

  • Did you ever figure this out?

  • @theopenem_admin Not yet, and now with the newest version of Win 11, I can't run the TOEC installer because it's telling me the system administrator has set a policy to prevent it. This is while in admin/audit mode.

  • I have verified it works correctly with the latest version of Win11, in audit mode, Toec installs fine and loads image prep fine. There must be something with your environment or your workflow.


  • @theopenem_admin I'm thinking it has something to do with the ISO I'm using to install. Going back to the drawing board on that. I'll update when/if I figure it out.