Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Imaging - Migrating from CloneDeploy

  • Hi,

    I have been handed a large batch of systems that no longer give the option to support legacy PXE so therefore unless I can overcome that at the hardware level I need to look at shifting from CloneDeploy to TOEMS. However time is short and my only requirement is Imaging over PXE so far.

    I have followed the documentation to install to a spare Windows SV2019 and can remote login to the webserver fine.

    My issue so far is that I am unable to get any sort of menu from the device when trying to EFI PXE however this could and is likely to be a simple fix.

    I also completed the WIE steps however I was hoping to deploy images in the same manner as clonedeploy which I believed used Linux/Partclone with the only differing been UFI supported PXE.

    Can anyone help steer me on the config for this?

    EDIT: The Server is also functioning as a temp DHCP until our main DHCP is setup. Would be trying to use this alongside a dedicated DHCP environment and without the use of ProxyDHCP as never been required before? DHCP Scope options 66/67 were set to TOEMSIP and pxeboot.0 but this was just amending what we did for CrucibleWDS/Clonedeploy.

  • To test, I have attempted to use Legacy PXE on a device that can and get the NBP file error (as expected as i am using an EFI bootfile on TOEMS) - but when attempting with IPV4 PXE boot (EFI) it fails.

    I took a video so I could get a capture of the error that shows for half a second.

    Server IP address is X.X.X.X
    NBP Filename is pxeboot.0
    NBP filesize is 0 bytes
    PXE-E18: server response timeout.

    this should give us a clue to the issue.

  • @aaron said in Imaging - Migrating from CloneDeploy:

    Server IP address is X.X.X.X

    Is the ip that shows up, the correct one for your Toems server? Did you set your pxe mode to ipxe efi and generate the boot files?

  • @theopenem_admin

    My actual server IP shows up (not X.X.X.X) and when testing TOKE app the device appeared in the com server.

    but it doesnt proceed to the boot menu, and yes I have created the boot files which has been same thing we do for Crucible/CD.

    to confirm I am using IPXE_EFI64

  • Run this file on your server.
    C:\Program Files\Theopenem\tftpd32\tftpd64_gui.exe
    Select the log viewer tab
    try a pxe boot
    post the log

  • I'm not really sure what that error means. Have you tried a different model just to see if it works?

  • @theopenem_admin it does this on any system. systems which do image using clonedeploy (using legacy)

    if i try and use legacy to reach UFI boot menu i get a different error saying the file is too large. which was mentioned in your video.

    I think behind the scenes this is hanging at the TFTP stage (which you cant see in UFI but can in legacy)

    EDIT, Logs from a legacy PXE attempt

    Connection received from on port 2070 [28/01 14:11:49.479]
    Read request for file <pxeboot.0>. Mode octet [28/01 14:11:49.479]
    OACK: <tsize=882048,> [28/01 14:11:49.479]
    Using local port 53785 [28/01 14:11:49.479]
    Connection received from on port 2071 [28/01 14:11:51.510]
    Read request for file <pxeboot.0>. Mode octet [28/01 14:11:51.510]
    OACK: <tsize=882048,> [28/01 14:11:51.510]
    Using local port 53786 [28/01 14:11:51.510]
    Connection received from on port 2072 [28/01 14:11:55.516]
    Read request for file <pxeboot.0>. Mode octet [28/01 14:11:55.516]
    OACK: <tsize=882048,> [28/01 14:11:55.516]
    Using local port 53787 [28/01 14:11:55.516]
    Connection received from on port 2073 [28/01 14:12:01.516]
    Read request for file <pxeboot.0>. Mode octet [28/01 14:12:01.516]
    OACK: <tsize=882048,> [28/01 14:12:01.516]
    Using local port 53788 [28/01 14:12:01.516]
    TIMEOUT waiting for Ack block #0  [28/01 14:12:04.563]
    TIMEOUT waiting for Ack block #0  [28/01 14:12:06.594]
    TIMEOUT waiting for Ack block #0  [28/01 14:12:10.609]

  • @aaron tried the same in UFI on the device that usually supports legacy and same as above , time out.

  • If you are using legacy boot, you need to change your pxe mode to pxelinux or a non efi ipxe

  • @theopenem_admin

    I understand, i was just testing both.

    As so far I've yet to have Legacy or UFI load a boot menu at all with TOEMS.

  • The logs you posted from the legacy attempt are very different and indicate that it would probably work if the correct bootloader was selected. I have come across some machines that just won't pxe boot. You'll need to use usb for those, if this is one of them.

  • @theopenem_admin

    Ill revisit the testing and see what happens.

    Same error in TFPT Log.

    but on screen Legacy PXE using Legacy BootFile I am getting.

    This is a system that does Legacy PXE without fault using CloneDeploy currently.

    PXE-T00 Undefined error code
    PXE-E36 Error received from TFTP server

    Willing to look at USB option depending on time it will take to deploy using that method, but as a last resort due to volumes and once proven TOEMS is working on our box.

    Guessing it still pulls image over the network just not via the PXE method but using a small OS on the stick?

  • Something with your network or on your server is preventing the tftp transfer.

  • @theopenem_admin I tested the USB method which worked fine, so at least that is something. I had to restore FW settings and may have now lost the rules created during install.

    Is there a list of ports I can open up or a way I can reapply the FW changes applied during install?

  • Further testing with opening ports has not made any improvement.

    I have tried to EFI PXE from 1 of each device and i get different errors.

    1 Device Model times out (Timeout Waiting for ACK Block) the second throws an error in TFTP advising "PEER RETURS ERROR <USER ABORTED TRANSFER>

    i tested all EFI pxe options in TOEMS but all get stuck same way at 0% of getting the pxeboot.0 file

  • I came accross this which looks like same issue.