Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

  • Image Size On Server: 17.56 GB
    However, under Image Profiles Minimum Client Size N / A
    A value is displayed here in your video part 3.
    20210216_181229 (1).jpg
    The server logs are attached

  • I would need to see the image upload log.

  • In my test environment I have now also installed the new version 1.3.2 on a new Win2019 server and repeated the entire setup. The deploy error remains. The required log is attached.

    Client Without Toec - Computers->Search Image Only->View->Imaging Logs

  • That's deploy log, I need upload.

  • @theopenem_admin Where can I find it?

  • @theopenem_admin We are some people here trying to get theopenem working together. The two log files from the client, via which the upload was carried out, are attached. Please give us a short reply if these should also be the wrong logs.



  • look at the imaging logs section from https://docs.theopenem.com/tutorials/logs/
    the location varies depending on how the computer is registered with Theopenem. You need to select the computer you uploaded the image from and select the upload log, similar to the deploy log. If you can't find it, then upload the image again

  • @theopenem_admin That should be the correct log.


  • The issue is that your image schema is corrupt because you have multiple efi bootloaders registered on this system. Is this a dual boot system? You have both a Windows and an ubuntu efi bootloader. Theopenem cannot handle a dual boot system.

    Here is your efi info, you can see both windows and ubuntu

    Current NVRAM Entries
    BootCurrent: 0003
    Timeout: 0 seconds
    BootOrder: 0003,0000,0008,0007,0001,0002
    Boot0000* Windows Boot Manager	HD(1,GPT,18d02f59-f2ad-4643-bfda-877f8331ef4a,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)****WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...3................
    Boot0001  ONBOARD NIC (IPV4)	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(b07b256ef462,0)/IPv4(,0,0)N.....YM....R,Y.
    Boot0002  ONBOARD NIC (IPV6)	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(b07b256ef462,0)/IPv6([::]:<->[::]:,0,0)N.....YM....R,Y.
    Boot0003* UEFI SanDisk Ultra 4C531001511009115583	PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/HD(1,MBR,0xeeb3d76,0x800,0x39ef800)/File(\EFI\Boot\BootX64.efi)N.....YM....R,Y.
    Boot0007  ubuntu	HD(1,GPT,5c6d39f4-41c7-44b1-b048-4313414ab98e,0x800,0x177000)/File(\EFI\ubuntu\shimx64.efi)
    Boot0008* UEFI KBG40ZNS256G NVMe KIOXIA 256GB X0APC1HMQ2C1 1	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,8C-E3-8E-04-01-3F-99-14)/HD(1,GPT,18d02f59-f2ad-4643-bfda-877f8331ef4a,0x800,0x32000)/File(\EFI\Boot\BootX64.efi)N.....YM....R,Y.
    The protective MBR's 0xEE partition is oversized! Auto-repairing.

  • @theopenem_admin Ubuntu was preinstalled by Dell. Good approach. Many Thanks!

  • If you update your schema to this, it should work.

    {"harddrives": [ {"name":"/dev/nvme0n1","size":"500118192","table":"gpt","boot":"","lbs":"512","pbs":"512","guid":"B38686FA-414F-4EA0-914B-BB040B4761F6","active":"true","partitions": [ {"number":"1","start":"2048","end":"206847","size":"204800","volumesize":"101","type":"","usedmb":"31","fsType":"vfat","fsid":"EF00","uuid":"4200-94A7","guid":"18D02F59-F2AD-4643-BFDA-877F8331EF4A","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"p","efibootloader":"Windows Boot Manager#\\EFI\\Microsoft\\Boot\\bootmgfw.efi","volumegroup": { } },{"number":"2","start":"206848","end":"239615","size":"32768","volumesize":"16","type":"","usedmb":"16","fsType":"","fsid":"0C01","uuid":"","guid":"1ACC9C3A-932F-48DB-AC8D-390BA8CA4483","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"p","efibootloader":"","volumegroup": { } },{"number":"3","start":"239616","end":"499060436","size":"498820821","volumesize":"27670","type":"","usedmb":"26864","fsType":"ntfs","fsid":"0700","uuid":"A6A401E7A401BAB7","guid":"C8F26185-9F11-40CF-A7C9-04EC581155A0","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"p","efibootloader":"","volumegroup": { } },{"number":"4","start":"499060736","end":"500115455","size":"1054720","volumesize":"515","type":"","usedmb":"439","fsType":"ntfs","fsid":"2700","uuid":"A2D6BC09D6BBDC2B","guid":"CE58390B-CF72-4E2F-9391-3311E39E21D2","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"p","efibootloader":"","volumegroup": { } }] }] }

    I've manually removed the ubuntu info from the schema. Find your image location in your filesystem, find the schema file, delete everything in it and replace with above.

  • @theopenem_admin The image was recreated today. The download still does not work. The error message is identical. The log file for upload is attached.


  • @sesam Thats the Upload-Log!


    Ok, just discovered that Ubuntu is still showing up. Will be checked again.

  • @sesam Sorry, that was the old upload log. Here is a new upload log without Ubuntu with the same Error.

    DESKTOP-87D3BNC-upload (2).txt

  • You still have 2 boot loaders listed even though Ubuntu is gone. I can make some changes so that only the first one is used if multiple are found, but that will need to wait until the next release. If you use the schema I provided it will work fine.

  • This should be fixed now with this commit.

    If you want to download that file and ovewrite the existing, it should fix your issue, otherwise it will be in the next release.

  • @theopenem_admin The accumulation of boot loaders is inexplicable. We therefore set up a brand new notebook: After deleting all partitions, installed Win10. Uploaded the image and successfully installed it on a new client. An update of the image that had already been carried out also worked without any problems and could be distributed. The upload log is attached.

    Thank you for your support. In the next step, we test the distribution of the images via PXE.


  • I've added another commit for this issue.


    Again, this will be in the next release.

  • @theopenem_admin Thanks for the new release. In the meantime, we were able to successfully download the image of 20 Dell Latitude 3150s via PXE.

    It was noticed here that the image is very large (240 GB). However, this jump did not show up until a rollback software was installed: Reboot RX. Could it be related? Tomorrow I will upload the upload log file here.

  • @sesamAs already mentioned, the image is very large and covers the entire size of the hard disk. Could this be related to the installed rollback solution "Remote RX". Here is the upload log file.