Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Secure Boot / WIM images not working

  • Hi All,

    I am having a huge issues with secure boot working, I have to shut off my secure boot and boot to the Linux files, and it works but I can't use WinPE the files that have been created by using the WIE_Builder. I have them in the location I think they are suppose to be in (instruction are vague at best) but it still won't boot. I need help with the following items.

    1. Where do i put the files that the WIE builder creates Currently they are here( C:\Program Files\Theopenem\tftpboot\images)
    2. If these images are secure boot why won't the computer use them
    3. How do I make Theopenem use these images vs the predefined Linux boot files.
    4. I can't generate the USB iso's when I attempt to download them from the server they comedown as a clientboot.iso (all of 2k in size)

    I also need to know if there is additional settings for DHCP to tell it to use the WIM images that WIE builder creates

    over all need some assistance here I can provide what ever is needed for this. Or if someone has a how to guide out there for this portion of the install that would be great.

    I just need to get secure boot, and the WIM and PXE working with them.

    Thanks, in advance !

  • Made some progress, I can now get it to boot to the WIM images but not receiving this error on them


  • There really shouldn't much to this. This is from the docs.

    If you are PXE booting, merge the tftp folder with your Theopenem Tftp Folder located at c:\program files\theopenem\tftpboot. You must do this on every com server. Change your PXE Mode in Admin Settings->PXE / Boot Menu->PXE Settings to the appropriate WinPE architecture. WinPE also works with the Toems Proxy DHCP to support both Legacy BIOS and EFI PXE booting simultaneously.

    When you build WinPE, there will be a tftpfolder in the builds directory. Just copy the tftpboot folder and paste on top of the tftpboot folder mentioned above. Change your pxe settings to match and you are good.

    The error you are receiving indicates you did not copy and paste the correct files into the correct locations

  • @theopenem_admin

    I have done this not sure what the problem is at all im assuming this will fix my secure boot thing as well (im on the 3rd round of making these images again ) Ill see what happens but may need to purchase support!

  • @theopenem_admin

    I am using Windows DHCP for this but not 100% sure what files i am to point to for it to do the boot can you assist me with that (there haven't been any instructions that I have found showing what each of the boot files are suppose to be this is what i have right now

    UEFI 64 Bit:


    UEFI 32 Bit:




    Am i suppose to point this to a different location ? did i miss something in the how to's ?


  • the bootfile name should always be pxeboot.0

  • @theopenem_admin I was able to get this fixed, I needed to point to each of the different ARCH to their respective bootmgfw.efi once I did this the WIM images worked just as expected ! Thanks for all of the help and assistance !