Welcome to the community forums for Theopenem. You are encouraged to not only ask questions but help others as well. If you have found Theopenem helpful in any way please consider purchasing a support contract. A support contract ensures the continued development of Theopenem as well as guaranteed responses to your questions in our helpdesk ticketing system.

ipxe EFI64 fails to download boot image. Could it be that ipxe needs an update?


  • Hi there,

    I am trying to get ipxe for EFI64 working on my install. I can use syslinux and grub on some devices, but would like to get ipxe working as well for more hardware support.

    I'm having the same issue as this post trying to get ipxe to work:

    https://forum.theopenem.com/topic/55/tftp-timeout-during-pxe-boot?_=1654861336035&lang=en-US

    I did try installing the old Clonedeploy cdproxy DHCP and disabled the new Toem's proxy DHCP. but, this didn't solve my issue.

    One thing I did try was to download the latest ipxe.efi file (1.21.1) from ipxe.org and replaced the existing ipxe.efi files (1.00) in the server. I was able to get ipxe to see my NIC, get an IP and download the pxelinux.0 file repeatedly, but never actually give me the boot menu. So it looks like it's maybe a hardware support issue with the old 1.00 version of ipxe and my newer Dell hardware. That's about the limit of my ability for troubleshooting.

    So my thought is would it be possibly considered to update ipxe in Theopenem in the future? Unless I'm going something wrong.

    Thanks so much!


  • I will update ipxe in the next version, not sure if it will resolve your issue though. As long as your device supports the universal network driver for pxe booting there typically isn't a problem.


  • @theopenem_admin That sounds good. Thanks! I'll definitely try again when it's updated.