Welcome to the community forums for Theopenem. All responses are provided by other users that wish to help out. Theopenem will not respond to these posts. If you require more assistance than what the community can provide, we offer various paid support options.

Process to Update already installed software

  • Hi

    I cant find in the doc's anywhere how to push out updates to app's already pushed out.

    Example: Adobe reader, i install it via the software module, but how do i update the module when a new version comes out?

    I have tried to by uploading and overwriting the existing files but i cant find how to tell TOE to push out the update on next check-in


  • generally, each version of an app should be it's own module, but if you want to overwrite, after you upload the new files, just deactivate your policy and activate it again. It will ask if you want to run it again on computers the policy already ran on.

  • @theopenem_admin Cheers, tried that. Will try another installer as it might be adobe reader that's being a pain lol


  • @pa_an_br Morning

    Tried everything and to get adobe to update lol. All others seems to work just not this one.

    Everything runs fine, files get cached, i can see the installer working and finishing without error but it just doesn't update. I've tried just the MSP, msp with msi and both with an mst.

    Event viewer doesn't show any errors either and reports install fine.

    If i uninstall it and force check-in, it will install without issue.

    Anything you can think of?

  • Are there any other install flags that need added to make an update work? Does it work if you run the file manually on the computer?

  • @theopenem_admin Ran just the MSP on its own and installed and updated Adobe with no issue.

    I ran the MSP manually from the cache folder.

    2022-04-25 15:24:34,867 INFO [36] ModuleSoftwareManager - Running Software Module: Adobe Reader April
    2022-04-25 15:24:34,867 DEBUG [36] ServiceProcess - Starting Command: msiexec.exe  /i  "C:\Program Files\Toec\AppData\4cd3db10-6697-4579-be0d-667d08d05d45\AcroRead.msi" PATCHES=[cache-path]AcroRdrDCUpd2200120117.msp;  
    2022-04-25 15:24:37,690 INFO [36] ModuleSoftwareManager - {"ExitCode":0,"StandardError":"\r\n","StandardOut":"\r\n"}
    2022-04-25 15:24:37,691 INFO [36] ModuleSoftwareManager - Software Module: Adobe Reader AprilFinished
    2022-04-25 15:24:37,692 INFO [36] PolicyExecutor - Finished Executing Policy ac5cbaaa-e560-4f69-bb99-a1a8cea64446 (Adobe Reader April)
    2022-04-25 15:24:37,693 INFO [36] PolicyRunner - Policies Complete.  Starting Policy Cleanup.
    2022-04-25 15:24:37,694 INFO [36] PolicyRunner - Submitting Policy Results
    2022-04-25 15:24:37,709 DEBUG [36] ApiRequest - ProvisionedComm/Policy/AddHistory/
    2022-04-25 15:24:37,878 INFO [36] PolicyRunner - Completed Submitting Policy Results
    2022-04-25 15:24:37,879 INFO [36] PolicyRunner - Cleaning Policy Cache
    2022-04-25 15:24:37,879 DEBUG [36] ServiceFileSystem - Deleting Directory C:\Program Files\Toec\AppData\4cd3db10-6697-4579-be0d-667d08d05d45

    the above is from me adding the MSI and MSP to a new policy and it running on the PC without issue but doesn't upgrade the install.

    Windows Installer reconfigured the product. Product Name: Adobe Acrobat Reader DC. Product Version: 15.007.20033. Product Language: 1033. Manufacturer: Adobe Systems Incorporated. Reconfiguration success or error status: 0.

    This is after the install and i've confirmed the MSP assigned to the policy is the correct one as per the naming of the MSP.


  • This looks like a bug with msp files. You can see the [cache-path] isn't being replaced by the actual cache-path. I'll need to address this in an update. You could just run this with your own arguments using the command module instead of the software module in the mean time.

  • @theopenem_admin Will do Thanks very much!